Make Plugins Compatible With Higher Versions of Firefox

January 26, 2011 at 2:44 pm (Uncategorized)

Well, I must admit that firefox is going through great change. Which enforces me to keep talking about it all the time. While, I updated my browser to the new Firefox 4 (beta), most of the add-ons stopped working because of version incompatibility,

However, I got a solution towards it. This way is a bit hacking but it works. Most, of the features of firefox are backword compatible and hence, no need to worry doing it.

In the firefox installation directory, there is a subfolder for extensions. All the add-ons get transferred there. All you have to do is to change the install.rdf file of the add-on.Following string marks the version compatibility check for the firefox, so, go ahead and change it.

<em:maxVersion>4.0b9</em:maxVersion>

In case, you are planning to install a new add-on, you can do the same thing before asking firefox to load it. This way compatibility check will pass and things woll keep working.

Another suggested way to do this is to update “extensions.checkcompatibility” flag in mozilla. All, these flags can be altered by hitting the URL “about:config”. Of course, you have to be careful while playing with these configs 🙂

 

Advertisements

1 Comment

  1. msamoodi said,

    😀 tq about that

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: